Configuring Mascot Distiller for Loading Quantitative Data into Scaffold Q+S

Scaffold is compatible with numerous search engines; however, they must be configured properly for Scaffold to read results. This document provides information on the configuration of Mascot to allow for the loading of quantitative data into Scaffold. SILAC and precursor intensity results must be processed using Mascot Distiller, a separate program that interfaces with the Mascot server, in order to be compatible with Scaffold Q+S. For data set specific inquiries or errors Proteome Software support is available from 8 AM to 5 PM PST Monday through Friday and can be contacted via support@proteomesoftware.com or by phone at 1-800-944-6027. 

Additional Documentation

Please see the Scaffold File Compatibility Matrix for the most up to date information on search engines currently supported in Scaffold.

Procedure

Viewing quantitative results requires the proper Scaffold quantitative module. Precursor intensity values can be viewed in Scaffold, Q+ and Q+S; SILAC data requires Scaffold Q+S. While Scaffold can view precursor intensities, the Q+ modules provide much more complex normalization and statistical analysis.

  • Open Mascot Distiller and select the File menu. Here you have two options: New Project for processing a single RAW file or New Multi-File Project for processing multiple RAW files. When running multi-file projects make sure to keep the memory-efficient box checked.
  • Select the manufacturer of the instrument you have and select your RAW files
  • Mascot Distiller starts the process by loading the file and displaying the Total Ion Current (TIC)
  • To search the RAW data using your in house Mascot server select Processing > Process and Search... This will bring up the Mascot search dialog.
  • Define the parameters that Mascot should use in the MS/MS search. These include the FASTA database, modifications, digestion enzyme and search tolerances. Note that SILAC modifications do not need to be selected as variable or fixed. 
  • Next the quantitation type must be selected. For precursor intensity choose Average [MD] from the dropdown. There are multiple options for quantitation via SILAC, make sure to choose the one that corresponds to the labels used in your experiment.

 

 mascot_precursor_intensity.png

Figure 1. Average [MD] selected for precursor intensitymascot_SILAC.png

Figure 2. An example of SILAC quantitation

  • You do not need to select a data file when running Mascot through Distiller
  • Click start to return to Distiller, Mascot will process the data in the background.
  • Once the search is finished the quantitation must be done. This can be done using the Analysis > Quantitate menu. Make sure to select the All Families radio button.
  • Once the quantitative values are calculated save the quantitative XML report using the Analysis > Quantitation Reports... menu. Select the Save Complete XML option.
  • Save the project using File > Save As, this will create a Mascot Distiller Project file (ROV). This ROV file is required for loading into Scaffold.
  • The data is now ready to be loaded into Scaffold. Make sure the ROV and XML file are located in the same directory. If Scaffold cannot access the Mascot search DAT file from the Mascot server then make sure to add the DAT file to the same directory as the ROV and XML files.
  • When loading the results into Scaffold make sure to select the proper quantitation method in the Load Data Wizard (Stable Isotope Labeling (Multiplex) for SILAC and Precursor Intensity (Standard) for precursor intensity).

 

mascot_dimethylation_2.png

Figure 3. Dimethylation [MD] selected for Dimethyl quantitation

A note about Dimethyl labeling. The process for processing Scaffold compatible data using Dimethyl labeling is almost identical to the procedure above with the one difference being the quantitation method. Select Dimethylation [MD] as the quantitation method. Scaffold Q+S is required to process this type of quantitative data..

Daemon Procedure

The Mascot Daemon is a software tool that can be used to automate data processing. Thus, each one of the steps listed above can be carried out automatically without any input from the user. Configure the daemon as follows to generate Scaffold compatible precursor intensity or SILAC data. Note, this procedure still requires that you have a licensed copy of Mascot Server and Mascot Distiller.

If you do not currently have the Mascot Daemon installed on your computer, a link to download the installer can be found on the homepage of you local Mascot server. Download the installer and run it on the same computer that Mascot Distiller is currently installed on. You will need to connect the Daemon to your Mascot server during the installation by adding the Mascot server URL. This can also be done using the Edit > Preferences > Intranet menu. The Daemon should automatically detect whether Mascot Distiller is installed or not.

Searches can be started by creating a custom parameters file. This will allow you to easily process data the same way repeatedly. You can create multiple processing files, one for each type of search you typically carry out. Configuring a few settings to be the same across each parameter file will ensure that Scaffold compatible results will be generated each time.

 

distiller_params.png

Figure 3. The Daemon parameter file editor. Make sure that the Decoy box is checked and the quantitation dropdown is set to either Average for precursor-intensity quantitation or SILAC. Then define the proper modifications, tolerances and a FASTA file.

Next, Mascot Distiller must be used as the Data import filter. This is selected using the Data import filter dropdown menu located in the Task Editor. Select Mascot Distiller and click on the Options... button.

 

data_import_filter.png

Figure 4. Select Mascot Distiller from the Data import filter dropdown. Then click on the Options... button

 

distiller_params_2.png

Figure 5. The Mascot Distiller options menu. Make sure the Save Distiller Project box is checked. Also, the All radio button should be selected in the Quantitate Protein Hits section. 

 

distiller_params_3.png

Figure 6. Open the Edit > Preferences > General tab. Check the box to Auto-export Mascot Distiller quantitation XML.

You can now return to the Task Editor tab and select the Parameter set and the raw files. Once this is done, click the Run button to start the job. Once processing is complete you should have a DAT file, a ROV file and an XML file. Load these files into Scaffold as described above.  

Have more questions? Submit a request

0 Comments

Article is closed for comments.