Scaffold DIA Release Notes

The following document contains release notes for Scaffold DIA

Scaffold DIA 3.0.1 Release Notes (2021-05-13)

Updated in-program help to enable text searches which were broken in version 3.0.0

Scaffold DIA 3.0.0 Release Notes (2021-03-18)

Added support for unique peptide counting

Added context menu option for showing only certain fragment ion series in the fragment chromatogram chart

Added an exclusivity column to the Samples view

Added a count of data and reference files in the workflow dialog

Added a "clear" button to the advanced filter dialog

Added peptide π₀ to the Publish view and the dashboard tooltip

Added tooltips to the column header in the Proteins view peptides table

Added tooltips to violin plots

Improved functionality of the volcano, quantitative scatter and PCA scores plots

Improved GUI behavior in the bulk edit sample names dialog

Improved performance for internal utility methods

Improved workflow GUI to simplify library selection, use clearer terminology and link to downloadable public libraries

Updated colors, icons, and GUI look-and-feel for Scaffold DIA 3

Updated error reporting to include current license ID in reports sent to Proteome Software support

Updated the default locations for some image exports and attribute file export

Updated Proteins view peptide table mass column presentation to match Scaffold LFQ

Updated terminology used for libraries in Publish view

Updated EncyclopeDIA from 0.9.6 to 1.2.2

Updated the Samples view color legend when switching "log intensities"

Changed the bottom pane of the Proteins view to show two tabs side-by-side; allow dragging tabs from side to sideChanged the bundled JRE to Java 11 in installers

Fragment chromatogram chart now scales vertically to optimally show quantified fragments

Only show searchable ELIBs when picking a library

Display more detailed messages in the progress dialog

Samples view now sorts proteins by total identified peptide count instead of protein score

Replaced usages of the plural "data" in the Publish view

Capture the Percolator version when searching only a single sample

Allow importing attributes files with a first column containing raw file names

Allow CLI workflows to override the default expected peak width used by EncyclopeDIA

Allow assigning attributes by dragging an attribute folder onto a sample

Allow copying selected text from the publish view

Allow the CLI to perform library searches with a workflow that doesn't specify modifications

Allow updating the msconvert location used for raw file conversion without restarting the program

Fixed incorrect scrolling to selected peptides in very long protein sequences

Fixed a bug that could cause incorrect normalization of counts for the selected protein after changing summarization or statistical test

Fixed a bug that could cause GO term clustering to randomly fail

Fixed a bug which could cause an error while recomputing heatmap clustering; improve performance of heatmap rebuilds

Fixed a bug that prevented proper opening of files when an attribute category's name contained leading or trailing whitespace

Fixed issues with cut-off text and keyboard focus traversal in the license entry dialog

Fixed a hang when copying an EMF image from the PCA scores plot

Fixed resizing of the Organize view when deleting a category; ensure buttons are consistently sized

Fixed a bug when imputing quantitative values with certain sample counts

Fixed an error when sample names contained long sequences of digits

Fixed bug in the summarization combo box that could prevent editing summarization

Fixed a bug causing the GO Term Filter to not appear when first applying GO terms

Fixed a bug that prevented loading searches with long mod names

Ensure that the currently-selected protein is visible when switching to the Samples view

Ensure that settings that won't affect the current search type are not written to workflow files

Ensure that the fragmentation table matches the fragment annotations provided by EncyclopeDIA when fragment masses are ambiguous

Ensure that the Samples view table header reflects renaming of attributes in all cases

Ensure that tooltips in quant trend charts correctly respect the "Log Intensities" option

Prevent potentially-lengthy threshold recomputation when the threshold hasn't changed

Do not attempt to launch the GUI after running the installer in headless mode

Do not show multiple rows for a protein group in the heatmap details

Do not display GO Terms that are associated with a protein with the "NOT" qualifier

Scaffold DIA 2.2.1 Release Notes (2020-09-04)

Scaffold DIA Bug Fixes

Removed check for loading of DDA data.

Modified the sort order in the Peptide Intensity Consistency Chart.

Scaffold DIA 2.2.0 Release Notes (2020-08-28)

Scaffold DIA Features

Enabled direct searching of Prosit libraries, MaxQuant msms.txt files, and MSP libraries.

Enabled display and editing of all modifications from a searched library in the workflow dialog.

Added support for libraries that contain multiple modifications on the same amino acid.

Modified the workflow dialog to obtain names for modifications found in search libraries from a Unimod file and to save custom names for future searches.

Allowed users to restrict the RT range during creation of *.dia files.

Added RT limits to the Publish View.

Allowed the user to specify the Percolator Training Set Size and Training Set FDR Threshold parameters.

Adjusted the default values for Percolator training set size and training set FDR threshold.

Added a check to attempt to identify when loaded data is not DIA.

Improved the fragment consistency metric.

Scaffold DIA Bug Fixes

Ensured consistency of results in repeated runs.

Corrected an error in the handling of modifications in library searches.

Changed the level at which the peptide intensity correlation metric is calculated if samples are fractions.

Allowed negative modification masses in the workflow dialog.

Corrected an error in the generation of the Peptide Report.

Changed the sort order in fragment intensity chart to reflect summarization.

Changed the sort order of ions in the chromatogram legend.

Ensured that the Peptide Intensities chart updates when switching between views.

Ensured that no FDR threshold is reported when the threshold is set to "No bound".

Made the background color of the Tools tab consistent with other tabs.

Ensured that the workflow dialog is rebuilt when a new version is run.

Removed RT Alignment parameter from Publish View for FASTA or DDA library searches.

Scaffold DIA 2.1.0 Release Notes (2019-12-19)

Scaffold DIA Features

Allowed the CLI to read a workflow file.

Enforced the ELIB file extension on reference libraries written by the program.

Scaffold DIA Bug Fixes

Corrected an error in the peptide sequence string in copying data from the Proteins View.

Supported searching MSP files with variations in format.

Prevented a potential deadlock when running on a single core.

Improved the warning message displayed when attempting to install with an expired contract.

Scaffold DIA 2.0.0 Release Notes (2019-11-13)

Scaffold DIA Features

Redesigned the Organize View.

Implemented block editing of sample names.

Implemented a new Experimental Design dialog.

Added support for repeated measures, two-way ANOVA and randomized block experiments.

Modified the SDIA file schema to provide improved GUI performance in large files.

Added the identification score for the highest scoring pepide match to the table in the Proteins View.

Added display of extracted chromatograms for unquantified peptides only in the sample in which the peptide achieved the highest identification score.

Improved performance when opening large files.

Added options to the Tools menu to support creation of searchable libraries from FASTA files via Prosit.

Added support for use of Prosit Libraries in searches. Prosit libraries are now available for download from the Proteome Software website.

Added the Raw File name as an optional column in the Organize View.

Allowed merged elibs created through the Tools menu to be treated as searchable in Scaffold DIA.

Added the amino acid residue to the modifications in the Edit > Preferences > Colors dialog.

Allowed the selection of a specific taxonomy when applying GO terms.

Enabled setting of memory limits from within program on Mac systems.

Added an option to turn off the cursor in the protein sequence display.

Added a menu option to change the “Always as a Viewer” setting.

Added a header, including the protein molecular weight and peptide count, to the protein sequence coverage display.

Added a warning that the user should save files which have been converted from a previous version.

Changed the protein sequence and protein coverage displays to respect filtering.

Added a tooltip to the protein sequence display in the Proteins View.

Redirected EncyclopeDIA console output to the Scaffold DIA logs.

Recreated the demo files.

Prevented installation of new versions if support contract has expired.

Made memory settings consistent across all operating systems.

Updated the code signing certificate.

Updated the installer file names.

Updated the default version of ProteWizard MSConvert to 3.0.19254 to support newer instruments such as the Exploris. The user may wish to install this version and update Scaffold DIA’s link to it when upgrading an existing installation of Scaffold DIA.

Allowed conversion of raw files to DIA format through the Scaffold DIA Viewer.

Scaffold DIA Bug Fixes

Corrected clustering of samples in the heatmap.

Corrected an error in the heatmap export.

Prevented running of the protein clustering algorithm during loading when not requested.

Corrected an error in normalization when samples are fractionated.

Allowed loading of data when one of the parameter sections is collapsed.

Corrected an error in applying statistical tests to fold-change display types.

Modified the large search space warning message.

Corrected an error in rebuilding the quantitative trend chart after updating sample organization.

Corrected an error that prevented display of multiple modifications in the protein coverage display.

Retained the Reference Library name in the Reference Library creation dialog box.

Added wait indication when changing display types in the Samples View.

Removed html tags from p-value column header in the export from the Samples View context menu.

Corrected an error in the displayed position of modifications in the protein coverage display.

Corrected a problem with the APFS on newer Mac operating systems.

Updated the message in the Add GO Annotation dialog.

Scaffold DIA 1.3.1 Release Notes (2019-03-13)

Scaffold DIA Bug Fixes

Fixed issue caused by protein that lacks exclusive peptides.

Scaffold DIA 1.3.0 Release Notes (2019-03-08)

Scaffold DIA Features

Updated EncyclopeDIA version to 0.8.1.

Added a Tools Menu to allow access to EncyclopeDIA utilities.

Changed the Protein Score calculation and FDR thresholding algorithm to provide more accurate FDR thresholding.

Added a Peptide-Profile Correlation metric to the Peptides Table in the Proteins View.

Added a Fragment Consistency score to the Peptides Table in the Proteins View.

Trimmed file paths in the Publish View.

Updated demo files.

Scaffold DIA Bug Fixes

Corrected an error in naming modifications with the same mass on different residues.

Corrected an error in loading workflow files for library searches with modifications.

Corrected an error in displaying the Protein Level Charts bar chart.

Scaffold DIA 1.2.1 Release Notes (2018-12-14)

Scaffold DIA Bug Fixes

Corrected an error in applying GO terms with filters in effect.

Added tooltips to headers in lower table Proteins View.

Fixed broken Help links in Edit > Preferences > System dialog.

Created a warning message to appear if a newer file attempts to open in an older version.

Scaffold DIA 1.2.0 Release Notes (2018-11-20)

Scaffold DIA Features

Added a Heatmap to the Visualize View.

Added the option to change the sample clustering method for Heatmap to the Edit>Preferences menu.

Added support for MSP, TRAML and some SPTXT libraries.

Modified the Workflow Dialog to display modifications that will be used in library searches, and allow editing for annotation purposes.

Added new display types.

Add the ability to save DIA files to a specified location as part of a regular Scaffold DIA run.

Added an option to the File menu to convert files to DIA format for later use in searching.

Added the ability to save custom modifications for re-use.

Added violin plots to the Proteins View and the Visualize View.

Added a chart showing peptide quantities across samples.

Expanded the list of selectable digestion enzymes.

Added a mechanism to specify a custom digestion enzyme.

Applied sorting to file names in the workflow dialog.

Added a tooltip to display full file name when hovering over a file in the Workflow Dialog.

Changed the fragmentation table to display three decimal places.

Added a message indicating successful addition of stars through the Volcano Plot.

Added the option to display quantitative values in intensity or log intensity form.

Added a tooltip to the cells in the Precursor M/Z column.

Added the program version number to the beginning of each session in the error log.

Added support for Agilent raw files.

Added the ability to specify window size in the Workflow Dialog.

Added the ability to register the program without an internet connection.

Scaffold DIA Bug Fixes

Ensured that values are displayed for protein groups even when exclusive quantitative display types are selected.

Changed to using only Y ions for identification when ion type is HCD and enzyme is trypsin.

Corrected an error that could prevent proteins meeting the threshold from displaying.

Corrected an error in updating the display when the summarization hierarchy is updated.

Corrected an error that sometimes prevented building of the PCA display.

Adjusted EncyclopeDIA parameters to use the number of processors specified by the user for Scaffold DIA.

Fixed the Print Protein Sequence option.

Ensured that charts update when proteins are starred or unstarred.

Improved regular expression handling in search fields.

Ensured re-creation of already existing DIA files in the same directories as selected raw files.

Corrected an updating issue in Publish View when Protein FDR is adjusted.

Corrected a logging error.

Disabled all exports when no file is open.

Trimmed white space from the ends of peptide search strings in the Peptide Sequence filter.

Modified the Workflow Dialog to allow the samples pane to expand.

Ensured that a save location is specified before enabling "Create Reference Library".

Corrected window type terminology in the Experimental Data Search Parameters pane of the Workflow Dialog.

Corrected window type terminology in the Publish View.

Improved input validation in the modification dialog.

Scaffold DIA 1.1.1 Release Notes (2018-06-12)

Scaffold DIA Bug Fix

Repaired start action on Load Data button for ELIB experiments.

Scaffold DIA 1.1.0 Release Notes (2018-06-01)

Scaffold DIA Features

Implemented an option, now the default, to quantify only on exclusive peptides.

Added a Quantitative CVs chart to the Visualize View.

Added a warning message to discourage resource-intensive FASTA searches.

Split fixed and variable modifications into two columns in the Proteins View.

Improved the method of imputing missing values.

Added precision to the log10 intensity values exported in reports.

Scaffold DIA Bug Fixes

Corrected the modification creation dialog to allow specification of protein terminal modifications without specifying a specific amino acid.

Ensured that peptides which are not quantifiable do not have the "Quantified" box checked in the Proteins View.

Corrected summarization behavior upon deletion of an attribute or attribute group.

Corrected an error in loading when “No Bound” is selected as the Target FDR option.

Inactivated the Peptide Match Report option when no file is open.

Inactivated the SQL Export option when no file is open.

Re-enabled the ability to navigate between panes using tabs in multi-pane views through the View > Navigate menu option.

Scaffold DIA 1.0.2 Release Notes (2018-05-18)

Scaffold DIA Features

Modified file browser used in selecting raw files to accept D directories.

Changed terminology of "multiplexed windows" to "staggered windows" for clarity.

Added the ability to process DIA files with no precursor scans.

Updated the code-signing certificate.

Scaffold DIA Bug Fixes

Corrected a file-handling error during combined experimental data search and reference library creation from an existing library.

Accommodated duplicate lines in FASTA files.

Corrected problem in over-writing reference library files.

Protected against invalid specification of a modification through the CLI.

Scaffold DIA 1.0.1 Release Notes (2018-03-12)

Scaffold DIA Bug Fixes

Fixed bug in which program deleted DIA files prematurely.

Scaffold DIA 1.0.0 Release Notes (2018-03-09)

Scaffold DIA Released!

Have more questions? Submit a request

0 Comments

Article is closed for comments.